[Bug 305764] New: Konqueror fails to use KWallet to store passwords in certain forms

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 305764] New: Konqueror fails to use KWallet to store passwords in certain forms

Bugzilla from marcus@harrisonland.co.uk
https://bugs.kde.org/show_bug.cgi?id=305764

            Bug ID: 305764
          Severity: normal
               URL: https://mtgox.com
           Version: unspecified
          Priority: NOR
          Assignee: [hidden email]
           Summary: Konqueror fails to use KWallet to store passwords in
                    certain forms
    Classification: Unclassified
                OS: Linux
          Reporter: [hidden email]
          Hardware: Other
            Status: UNCONFIRMED
         Component: general
           Product: konqueror

On certain forms (perhaps forms with action="#" or similar?), Konqueror fails
to register that the form has been submitted and does not show the KWallet bar
asking the user if they would like to save the password.

Reproducible: Always

--
You are receiving this mail because:
You are watching all bug changes.
Reply | Threaded
Open this post in threaded view
|

[Bug 305764] Konqueror fails to use KWallet to store passwords in certain forms

Bugzilla from marcus@harrisonland.co.uk
https://bugs.kde.org/show_bug.cgi?id=305764

--- Comment #1 from Marcus Harrison <[hidden email]> ---
I forgot to mention: I have tested this using both KHTML and kwebkitpart 1.3.

--
You are receiving this mail because:
You are watching all bug changes.
Reply | Threaded
Open this post in threaded view
|

[Bug 305764] Konqueror fails to use KWallet to store passwords in certain forms

Myriam Schweingruber
In reply to this post by Bugzilla from marcus@harrisonland.co.uk
https://bugs.kde.org/show_bug.cgi?id=305764

Myriam Schweingruber <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |NEEDSINFO
         Resolution|---                         |WAITINGFORINFO

--- Comment #2 from Myriam Schweingruber <[hidden email]> ---
And which exact Konqueror version is this about? Please set the version field
accordingly.

--
You are receiving this mail because:
You are watching all bug changes.
Reply | Threaded
Open this post in threaded view
|

[Bug 305764] Konqueror fails to use KWallet to store passwords in certain forms

Bugzilla from marcus@harrisonland.co.uk
In reply to this post by Bugzilla from marcus@harrisonland.co.uk
https://bugs.kde.org/show_bug.cgi?id=305764

Marcus Harrison <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|unspecified                 |4.9.0

--- Comment #3 from Marcus Harrison <[hidden email]> ---
Konqueror 4.9.0. I've set the version number now.

--
You are receiving this mail because:
You are watching all bug changes.
Reply | Threaded
Open this post in threaded view
|

[Bug 305764] Konqueror fails to use KWallet to store passwords in certain forms

Bugzilla from marcus@harrisonland.co.uk
In reply to this post by Bugzilla from marcus@harrisonland.co.uk
https://bugs.kde.org/show_bug.cgi?id=305764

--- Comment #4 from Marcus Harrison <[hidden email]> ---
I have tested this on the Mt.Gox website, and this bug still occurs.

To clarify: Konqueror doesn't even ask to save the password in KWallet. If the
information is added to KWallet manually, Konqueror successfully loads it from
KWallet.

Not sure what other websites this happens with.

--
You are receiving this mail because:
You are watching all bug changes.
Reply | Threaded
Open this post in threaded view
|

[Bug 305764] Konqueror fails to use KWallet to store passwords in certain forms

Myriam Schweingruber
In reply to this post by Bugzilla from marcus@harrisonland.co.uk
https://bugs.kde.org/show_bug.cgi?id=305764

Myriam Schweingruber <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDSINFO                   |UNCONFIRMED
         Resolution|WAITINGFORINFO              |---

--- Comment #5 from Myriam Schweingruber <[hidden email]> ---
Setting status correctly.

--
You are receiving this mail because:
You are watching all bug changes.
Reply | Threaded
Open this post in threaded view
|

[Bug 305764] Konqueror fails to use KWallet to store passwords in certain forms

Dawit Alemayehu
In reply to this post by Bugzilla from marcus@harrisonland.co.uk
https://bugs.kde.org/show_bug.cgi?id=305764

Dawit Alemayehu <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |NEW
                 CC|                            |[hidden email]
     Ever confirmed|0                           |1

--- Comment #6 from Dawit Alemayehu <[hidden email]> ---
This is a known issue at least for kwebkitpart. See bug# 287689.

--
You are receiving this mail because:
You are watching all bug changes.