Re: [Bug 676398] Re: Kexi Package Way Too Monolithic

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [Bug 676398] Re: Kexi Package Way Too Monolithic

Jaroslaw Staniek-3
>> Kexi Package Way Too Monolithic
>> https://bugs.launchpad.net/bugs/676398

On 17 November 2010 15:24, Jonathan Riddell <[hidden email]> wrote:
> I don't see installing a couple of database access libraries as being a
> problem.  libsybdb5, libxbase2.0-0 and libpqxx-3.0 aren't large and
> don't require installing the actual database server.

Jonathan,
I have to disagree. All distros properly packaging Kexi have the splitting.
What you say is not excuse for giving up with splitting. Lack of time is.
But the issue was reported to Debian years ago in the time of KOffice
1.4 and now to Ubuntu.

> Splitting up kexi would have people install and run kexi then wonder why
> it wasn't connecting to their preferred database.  Working out that you
> have to install another package isn't a great user experience.

The idea of recommended packages can address that.
In next version plugins would depend on kspread and maybe on openoffice.
Would it make sense to make Kexi dependent on those? This degrades its value.
Would you also add this dependency?

--
regards / pozdrawiam, Jaroslaw Staniek
 http://www.linkedin.com/in/jstaniek
 Kexi & KOffice (http://kexi-project.org, http://identi.ca/kexi,
http://koffice.org)
 KDE Software Development Platform on MS Windows (http://windows.kde.org)
____________________________________
KOffice mailing list
[hidden email]
To unsubscribe please visit:
https://mail.kde.org/mailman/listinfo/koffice